A Short History of DB2000

In the late nineties, a Windows based piece of software, DB2000, made its first appearance. Written
by P/D/C Ken Guscott, DB2000 was conceived by its design team to be a squadron management
tool capable of handling all the record keeping and reporting requirements necessary in a squadron.

It began as a replacement for the existing limited software products, Squadron Management
Software (SMS) and Biographical Data Update (BDU), which provided a mechanism to dial into
headquarters, request a roster, call back later and download the roster. Then the downloaded roster
could be used in user supplied various products to create reports and labels.

DB2000 began as a simple database with the ability to import an encrypted roster from
headquarters, received by email, to apply changes to the database. The changes could then be sent
back to headquarters as an encrypted BDU file. Over the years, and countless versions, numerous
additions and enhancements have been made, the most recent being support for Electronic Merit
Mark (EMM) processing and electronic filing of Historian reports.

DB2000 Requirements

To use DB2000, you must have a personal computer running Microsoft Windows. The MAC is not
supported unless some type of virtualizing software is installed. It has been used successfully with
Parallel, BootCamp, and Virtual/PC. Parallel is the best approach if your MAC has an Intel
processor. We have users using Win/95, Win/98 Win/SE Win/NT Win/2000 Win/XP; and various
versions of Vista (boo) however Windows XP with SP2 is the preferred environment.

DB2000 communicates with programs and headquarters via the Internet thus you must have an
Internet connection. A DSL or cable connection lubricates the entire process.

DB2000 communicates with headquarters by one of two ways; it either sends or receives files via an
email attachment, or it communicates directly with the headquarters computers in real time using
messaging software known as ‘MQSeries’. Email is slow, and, especially on weekends, not always
available. ‘MQSeries’ connects directly with Headquarters and is usually available 24/7.

Note:

‘MQSeries’ requires that your security software and/or firewall permit TCP communications
on ports 1414-1415. If you are running on a corporate installation, the company policies or
the difficultly in opening these ports may preclude using MQSeries.

In most private installations, problems are not usually encountered with ‘MQSeries’ and makes
using DB2000 very fast and convenient. Once installed, it is much easier and faster than email.

Acquiring the Software

For a fully functional DB2000 installation, there are two necessary pieces of software, DB2000 and
the MQSeries client. (As previously stated, Email can be substituted for MQSeries, if necessary).

The programs can be acquired on a CD from headquarters, or broadband users can easily
download them from the DB2000 support site. The site URL is:



HTTP://WWW.ACCURECORD.COM/USPS/OUTGOING/DOWNLOADS.HTM

The DB2000 full install file is named DB2000R3.EXE and is about 19 Meg in size. Note that at least
version 8.0.4 of DB2000 is required to support the current EMM features.

The MQSeries client install file for XP and other NT based systems is named MACPENnUS.ZIP and
is about 10 Meg in size.

The MQSeries client install file for Vista is named MQC6_WIN.ZIP and is about 135 Meg in size.

The MQSeries client install file for Win/95, Win/98, and Win/ME is named MACJENnUS.ZIP and is
about 4.5 Meg in size.

We strongly suggest creating a new folder on your machine directly under the root folder of your C:
drive named C:\DOWNLOADS.

You may create this folder by doing the following:

Click the ‘Start’ button

Then click or double-click, as appropriate for your system, on the ‘My Computer’ icon to open ‘My
Computer’.

Open Local Disc (C :) so that C:\ shows in the address bar at the top.
Click on the ‘File’ menu in the top tool bar.

Select ‘New’, and then ‘Folder’:
(This will create a folder named ‘New Folder’ and leave the name in a selected state.)

» Overtype the name ‘New Folder’ with ‘DOWNLOADS’ and then press enter.

NOTE:

Some users’ browser security settings are so restrictive that they prevent the browser from
properly handling some of the links on the download page. This failure usually manifests
itself in a message something like “This Page Cannot Be Displayed’. If this error occurs
when you click on one of the links on the download page, do the following:

Instead of left clicking on the link, right click on it.
This will open a context sensitive menu.
From this menu, select the option which is closest in meaning to ‘Save Target As...".

This will open a dialog box which will allow you to navigate to the folder that will be used for the file
download

Use the dialog to navigate to the ‘C:\DOWNLOADS'’ folder.

When the ‘Save In’: bar at the top contains ‘DOWNLOADS’, click on the ‘SAVE’ button to
download the file and save it in the ‘C:\DOWNLOADS’ folder.

Installing the Software




Before installing DB2000 using the full install file, insure that there is no existing version on your
system. Do this by using the ‘Control Panel’ ‘Add/Remove Programs’ applet. It will begin by
creating an alphabetic listing of all of the software installed on your system. This sometimes takes a
couple of minutes. When the search is complete, look for ‘DB2000V3’ in the list.

If you see any previous version, select it and then click the ‘Add/Remove’ button to uninstall the
previous version.

Have no Fear! This will not affect any existing databases or saved entries.

While you have the list of Installed software available, check to see whether there is an entry for
‘IBM MQSeries’ or ‘IBM WebSphere MQ'. If there is, just remember that fact, so you won't have to
download or install it later.

Installing DB2000 is no more complicated than locating the install file ‘DB2000R3.EXE’, in the
‘Download’ folder, double-clicking on its name to start it, and then responding to a couple of
guestions by clicking on the ‘OK’ buttons, A screen will then appear with an ‘Install Icon’, click it
and allow the install program to choose its own folders.

NOTE: If you determined previously that the MQSeries Client is already installed on your machine,
then, skip the following install procedure.

Installing the ‘MQSeries Client’ is a little more complicated but not much. All of the files are ‘zip’
files, created by IBM and distributed by us for your convenience. The ‘zip’ file containing the install
files for the ‘MQSeries client’ for XP and Win/2000 is named ‘MACPENnUS.ZIP’. The same file for
Win/95, Win/98, and Win/ME is named ‘MACJEnUS.ZIP’. The file for Vista is named
‘MQC6_Win.ZIP’. Check and be sure you downloaded and saved the correct file from the download
center.

Right-click on the file name, and from the context sensitive menu that opens, select the
option“Open With” (not Open) and then select “Compressed (zipped) Folders”.

At this point it would be a good idea to click on the ‘View Menu’ and select the ‘Details’ mode to get
on the same page with these instructions. Each of the files contains subfolders, one is named
licenses, and another is named either WIN95, WINNT, or WINDOWS depending on which version
you are installing. Open the folder beginning with WIN. If you see a subfolder named ‘setupEn’.
Open that folder also. At this point you should see a file named SETUP.EXE.

NOTE:

Depending on your windows setup, you may or may not see the suffix *.EXE’. If you do not see it,
you will see several files, all named Setup. If your file listing shows the ‘Type’ of file, select the one
with a Type of ‘Application’. If you still can’'t determine which is the proper file to execute, then do
the following:

* Click on ‘Tools’ on the top bar.

* Select ‘Folder Options’

* Select the ‘View’ Tab

* In the big box that opens, locate ‘Hide extensions for known file types *

* UN-Check the box next to it, to turn off the option (you will now see the ‘file extensions’ on all
files).

* Click on the ‘Apply’ button and then the ‘OK’ button



* Click on the *View’ Menu and select ‘Refresh’

* The ‘.exe’ suffix should now be visible.

Double click on the ‘SETUP.EXE’ file to begin the install of the MQSeries Client. Allow the install
procedure to select its own folders, etc. Respond to any questions affirmatively(Yes or OK). If it asks
any questions about what to install, select only the ‘client’. (You do not need the Development
Environment, etc.)

At the end of the install procedure you will need to ‘re-start’ your machine. If it doesn’t ask, reboot
your machine anyway.

At this point you have installed DB2000V3 and the MQSeries Client, and its time to configure
DB2000.

Configuring the Software

When you start DB2000, does the leftmost menu say ‘File or Start’? If it says ‘File’, then DB2000
has picked up your previous configuration, and you can continue below with the paragraph entitled:
‘Setting User Authorization Values'.

Otherwise, click on the DB2000 ‘Start’ menu. It will respond by presenting a pull-down list to select
the proper ‘District’. Click on the down arrow to open the list and reveal the available selections.

if you will be working on a provisional squadron choose ‘District 90'.
If you will be working on a National committee or department choose ‘District 60’.

Otherwise, choose your appropriate district.

Once you have made your selection, the system will ask you to confirm it.

Next, if ‘District 60’ was not selected, the system will present another pull-down list to allow selection
of the squadron within the previously selected district.

If you will be working on a District, select the District entry from the top of the list, otherwise select
the appropriate squadron.

The system will ask you to confirm your choice.

Following the specification of the District or the Squadron, the menus will change and a ‘File’ menu
will be present.

Setting User Authorization Values

Click on the ‘Settings’ menu and select ‘User Authorization’.
Enter your Certificate Number in the first box.

The password in the second box is used to authenticate DB2000 roster retrieval and/or updating.



Enter your squadron or district's user or updater password (This is available from the Commander)
in the second box depending on whether you are the roster updater or merely need to acquire the
roster for your personal USPS use..

The password in the third box is used for Electronic Merit Mark submission. If you are not doing
Electronic Merit Marks, this password can be omitted, otherwise enter the password supplied by
your commander.

R/Cs and V/Cs using the D/60 roster to do National committee or department merit marks should
use the password supplied to them by letter and should also enter this password in the second box.

Setting MOSeries parameters.

If you have installed ‘MQSeries’ you must set the MQ Connection Options otherwise you can
Ignore them.

Click on the ‘Settings’ menu and select ‘MQ Connection Options’.
If you are using any type of permanently connected broadband connection such as DSL, CABLE, or
T1, select the “Never Hang Up” option. Otherwise dial users should select the “Hang Up Only If

Connection Made By DB2000” option. The Timeout setting in all cases can remain at 180
seconds.

Acquiring a Roster File From Headquarters

If, when you click on the Roster Button, the roster is empty, or outdated, you will need to acquire a
new roster from HQ otherwise you can bypass this step.

Click on the Import menu. If the Download option is available meaning DB2000 recognizes that the
MQSeries Client has been installed, select that option and continue with “Acquiring a Roster by
MQSeries” below. If the Download option is grayed out, select the “Request Roster from
Website” option and continue with “Acquiring a Roster by Email” below.

Acquiring a Roster by MOSeries

When you select Download from the Import menu, a very small window will open in the lower left
corner of the screen. This window will provide continuing status as the download process proceeds.
Normally, it will move from Initialize, to Connecting, to User Rights, to DL Roster, to DL Modules,
and finally to Finished.

NOTE:
There are generally 4 errors that can occur in this process.

1. The system says that the MQ.DLL can’t be found. What this really means is that the MQSeries
Client install has either not finished, or completed unsuccessfully. The first thing to do is to reboot
and see if this error persists following a reboot. If it does, go to the section at the end of this
document entitled “Problems With the MQSeries Client Install” below.

2. DB2000 reports an error 2059. This error means that MQSeries can’t communicate with the
network. In 95% of cases, this is caused by a program being prevented from reaching the internet



by either a firewall or a security program such as Norton or McAffee. You will need to determine
what program is stopping the TCP/IP communication and configure it to allow DB2000V3 to
communicate on port 1414. In the remaining 5% of cases, the headquarters computer is down, and
you will need to try latter.

3. The small MQSeries window in the lower left never gets past the state of “Connecting” and times
out after 180 seconds. In this case, the server at HQ may be down. While this is not common, it
does occur from time to time. If you encounter this problem, send a notification email to
itcom@usps.org.

4. DB2000 reports a password error. This means that the password you supplied back in the section
entitled Setting User Authorization Values is incorrect. Go back and check it. Make sure that you
enter it in all UPPERCASE letters.

Acquiring a Roster by Email

If you are unable to use MQSeries, you must rely on Email to request and receive rosters. ltis a
two step process.

The first step is to request the roster. Click on the Import menu and select ‘Request Roster from
Website'. If everything is properly configured, DB2000 will open your internet browser, and send all
of the necessary parameter values to a page on the USPS web server. If everything works properly,
you will see the page in your browser with the message Request Submitted OK at the bottom. If
this is the case, simply close the browser and wait for the roster to arrive attached to an email.

If there is some other message at the bottom, respond appropriately.

If for some reason DB2000 was unable to open your browser or submit the request, go to the
following URL and supply the four values manually.

http://www.usps.org/national/itcom/roster/submit request.php3

The second step is detaching the roster from the email and saving it in the C:\DOWNLOADS folder.

The attachment is usually named SQD??7?.EX_, where the question marks represent your
squadron or district code. When you receive the email from headquarters with the roster file
attached you will need to save the attached file in the C:\downloads folder. Do this by right clicking
on whatever your browser uses to represent the attachment. It is usually an icon, but may be a link.
Right-clicking presents a context sensitive menu. Select the Save As or Save Target As and use
the resulting dialog to navigate to the C:\DOWNLOADS folder.

When C:\DOWNLOADS is in the top location field, click on the Save or OK button to save the
attachment.

Importing an Email Roster File

Select the Import menu and select Update with Email Roster File. This will open a blue dialog
window with a bunch of check boxes and a Start button on the lower left. Make sure that all the
check boxes are checked and then click on the Start button.




That will open a Windows Open dialog. At the top of this dialog you will see a white box labeled
Look In: click on the button with the down arrowhead located on the right end of the Look In box.

This will open a pull down list of drives and folders. Scroll up to the top if necessary and select the
entry which refers to Local Disk (C:). The large white box in the center will then show all of the
folders located under the root of your Local Disk C: Scan down and double-click on the
DOWNLOADS folder in this list. At this point you should see the file you detached from the Email
and saved in this folder. Click on its name to select it and then click on the Open button on the
bottom right of the dialog. If you do not see the file’'s name in the large white box, then you have
done some previous step wrong and will need to go back to the second step of the section entitled
Acquiring a Roster by Email and redo it correctly.

Once you succeed in selecting the saved file and clicking on the Open button in DB2000, DB2000
will return to the blue dialog and begin importing the roster file.

During the importing process, DB2000 will advise you of any wrong situations it encounters in the
roster file. For the most part these will relate to the record on the roster file being older than the
record in your database. You can elect to skip importing any record or all records like this.

When the import is finished, DB2000 will, if the situation occurs, provide a list of records on the
database which are no longer in the roster. These are records of members who didn’t renew,
transferred, or died. You are given the option of removing any or all of these records from your
database, or tagging any or all of them for later identification purposes. When you are done with this
process, click on the Finish button to return to the main screen.

Problems with the MQ Series Client Install

If you have attempted the corrective actions mentioned previously in this document and are still
getting a message indicating that the ‘MQ.DLL’ cannot be located, do the following:

Open the Help menu in DB2000

Select the Installation Log option and then “Make Diagnostic File”.

Open the Help menu in DB2000

Select the Installation Log option and then “Email File to Help Desk”.



